0.4.0-alpha

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

0.4.0-alpha

Postby gloomyandy » Sun Sep 22, 2013 9:10 pm

Hi Folks,
I am now in the process of pushing 0.4.0-alpha to git and the download page. New for this release:
* Now include kernel source bundle to make it easier to build the kernel. This is basically the standard Lego kernel source along with a small patch file.
* Added backports project to get updated WNA1100 drivers. So WNA1100 dongles should now work again!
* Fixed udev so the SD card is not automounted for a second time.
* Faster and more robust UART sensor initialisation.
* Attempt to recover from UART sensor resets and other errors.

Please note that due to the kernel source bundle the git download might take a very long time (the upload certainly is!). But I don't expect this bundle to change so hopefully you will only need to download it once.


Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4113
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.4.0-alpha

Postby jerryP » Sun Sep 22, 2013 11:55 pm

Thanks Andy,

It looks good.

Jerry
jerryP
New User
 
Posts: 18
Joined: Mon Aug 19, 2013 12:32 am

Re: 0.4.0-alpha

Postby fuzzycow » Wed Sep 25, 2013 9:24 pm

Thanks !

Atheros Wifi dongle wireless is working for me.
fuzzycow
Novice
 
Posts: 28
Joined: Sun Sep 08, 2013 4:33 pm

Re: 0.4.0-alpha

Postby gloomyandy » Mon Sep 30, 2013 11:12 am

Folks,
please be aware that there are now a lot of changes going into out git repo. Try them out if you want but be aware that they may not be complete or stable. If you want to (slightly) more stable setup make sure you pull one of the tagged configurations.

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4113
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.4.0-alpha

Postby pepijndevos » Tue Oct 08, 2013 11:06 am

How dow we use the git version? Is there something to compile using make or ant or whatever?
pepijndevos
New User
 
Posts: 24
Joined: Fri May 14, 2010 8:56 am

Re: 0.4.0-alpha

Postby gloomyandy » Wed Nov 13, 2013 8:38 am

Folks,
as I mentioned above there are a lot of changes in the master part of our git repo. If you compile your programs against an ev3classes.jar built from master you can not run this code using the ev3classes.jar shipped with the 0.4.0-alpha sd card. It simply won't work. The safe thing to do is to use the code from the repo that was tagged with 0.4.0-aplha. The following thread has more details:
viewtopic.php?f=18&t=4782

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4113
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK


Return to EV3 Software

Who is online

Users browsing this forum: No registered users and 2 guests

more stuff