[Solved] EV3 won't boot from SD Card

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

[Solved] EV3 won't boot from SD Card

Postby ezephyr » Sat Oct 26, 2013 12:29 am

Hey all, I followed the instructions for formatting my sd card and updating the partitions with the 0.4.0 download from sourceforge. When I insert it into my EV3 and then power it up, it brings up the

Code: Select all
MINDSTORMS
---------
starting..


Screen as a normal (sans SD card) boot does. But then, nothing happens. I've let it hang out there for up to about 5 or 10 minutes before I get impatient and remove the battery...

Any thoughts as to what might be the problem?

Some general info:

I formatted the sd card on laptop running linux mint 15. I had to do the formatting commands myself because the device that it started under wasn't an /dev/sd? it was /dev/mmcblk0 and then the partitions created by fdisk were /dev/mmcblk0p1 and /dev/mmcblk0p2.

I'm assuming that this is simply an idiosyncrasy of the computer that I did the formatting on, but it also occurred to me that this could be preventing the boot in some way...

Any other information I can provide I'm happy to. thanks!!
Last edited by ezephyr on Sat Oct 26, 2013 12:51 am, edited 1 time in total.
ezephyr
New User
 
Posts: 5
Joined: Sat Oct 26, 2013 12:04 am

Re: EV3 won't boot from SD Card

Postby ezephyr » Sat Oct 26, 2013 12:51 am

I found the answer to my problem already on this very forum! http://www.lejos.org/forum/viewtopic.php?f=18&t=4480&start=45#p19908

So apparently something is wrong with my wireless setup because I boot and can connect over USB just fine when no wireless is connected.

Now to debug my wireless config!
ezephyr
New User
 
Posts: 5
Joined: Sat Oct 26, 2013 12:04 am

Re: [Solved] EV3 won't boot from SD Card

Postby marvin » Thu Oct 31, 2013 4:22 pm

Hello,

did you have success?

I ask because there may be also a problem with your sd card. I had a 2 GB SanDisk card which worked flawlessly with linux and the card reader - but no way with the ev3. I also have another 2 GB SanDisk card which works with the ev3 also. So there may be some generations of sd cards which are working and other with won't. Even from one manufacturer.

Just if you are still searching...

Bye marvin
--
I am feeling very depressed...
marvin
Novice
 
Posts: 26
Joined: Mon Mar 19, 2012 12:47 am


Return to EV3 Software

Who is online

Users browsing this forum: No registered users and 3 guests

more stuff