0.8.1-beta release hangs at start menu

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

0.8.1-beta release hangs at start menu

Postby krchilders » Fri Apr 18, 2014 10:53 pm

I installed on the SD card with no problem. However, when I booted the EV3 with the card it went through the whole setup and then stopped at "Start menu...". I shut it down and then restarted. Again got as far as "Start menu..." and then stopped.
krchilders
New User
 
Posts: 11
Joined: Tue Mar 18, 2014 10:49 pm

Re: 0.8.1-beta release

Postby gloomyandy » Sat Apr 19, 2014 12:00 am

krchilders are you sure you have copied the Java JRE to the SD card and that it is the correct version? It needs to be Java 7 not Java 8? If you are sure please try the setup again and make sure you have deleted all of the files from the DOS partition before you start.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4082
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.8.1-beta release

Postby krchilders » Sat Apr 19, 2014 12:07 am

I downloaded ejre-7u55-fcs-b13-linux-arm-sflt-headless-17_mar_2014.tar.gz. I pointed to that when the SD card formatter came up during the installation

I reformatted the SD card using SD500 before I wrote to it so I suppose I wiped it clean.
krchilders
New User
 
Posts: 11
Joined: Tue Mar 18, 2014 10:49 pm

Re: 0.8.1-beta release hangs at start menu

Postby gloomyandy » Sat Apr 19, 2014 12:13 am

Please reformat the SD card and try the install again. Please take care to eject the sd card from your windows system before you move it to the EV3.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4082
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.8.1-beta release hangs at start menu

Postby krchilders » Sat Apr 19, 2014 1:12 am

Used jre 7u51 and it started up just fine.
krchilders
New User
 
Posts: 11
Joined: Tue Mar 18, 2014 10:49 pm

Re: 0.8.1-beta release hangs at start menu

Postby gloomyandy » Sat Apr 19, 2014 8:36 am

Did you ever just retry (as I requested) with the 55 JRE or did you just jump straight to 51?
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4082
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.8.1-beta release hangs at start menu

Postby krchilders » Sat Apr 19, 2014 1:08 pm

I did this morning. Worked just fine. Thx!
krchilders
New User
 
Posts: 11
Joined: Tue Mar 18, 2014 10:49 pm

Re: 0.8.1-beta release hangs at start menu

Postby cyjohnson » Mon Apr 21, 2014 5:24 am

It didn't work for me the first time because I already had a leJOS version running on the card previously.

It appears that you must reformat (FAT32) first, then upgrade. If you don't reformat, the LeJOS bootup looks like it is working, but then stops after awhile.

To format, I used "SD Formatter 4.0 for SD/SDHC/SDXC" from SDCard.org

https://www.sdcard.org/downloads/formatter_4/

Supports both windows and mac.
cyjohnson
New User
 
Posts: 3
Joined: Mon Apr 14, 2014 3:00 pm

Re: 0.8.1-beta release hangs at start menu

Postby yoshio » Tue Apr 22, 2014 8:20 am

I faced the same problem.
At first,
I installed leJOS:0.8.0-alpha and Java SE Embedded 7u51.
And it worked fine.

After released the leJOS:0.8.1-beta and Java SE Embedded 7u55,
I had tried to upgrade both version.

Even though I re-formatted the SD card by using "SD Formatter",
the leJOS hangs during the system boot at "Start menu ..."

I used following and created the image on Mac OS/X 10.9.2.
leJOS_EV3_0.8.1-beta.tar.gz
ejre-7u55-fcs-b13-linux-arm-vfp-sflt-client_headless-17_mar_2014.tar.gz

Did anyone success the above environment ?
yoshio
New User
 
Posts: 3
Joined: Tue Apr 22, 2014 8:05 am

Re: 0.8.1-beta release hangs at start menu

Postby gloomyandy » Tue Apr 22, 2014 8:28 am

If the system hangs at start menu, then there is a good chance that there is a problem with the Java install. If you can open up a shell (via telnet/ssh) to your EV3, login and try running java to see what happens. If you can't do that try the older jre.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4082
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.8.1-beta release hangs at start menu

Postby yoshio » Wed Apr 23, 2014 9:45 am

Dear gloomyandy.

Thank you so much for your reply.
If the problem occurred after the boot, I will be able to access to EV3 via telnet/ssh.
However it occurred on during the installation of the leJOS.
Thus I couldn't configure the WiFi access point nor WEP password on it.
It is impossible for me to use the telnet/ssh and can't confirm the problem now.

Instead of u55,
I'm using previous version of JRE and worked fine with 0.8.1-beta.
ejre-7u51-fcs-b13-linux-arm-sflt-headless-18_dec_2013.tar.gz
yoshio
New User
 
Posts: 3
Joined: Tue Apr 22, 2014 8:05 am

Re: 0.8.1-beta release hangs at start menu

Postby gloomyandy » Wed Apr 23, 2014 11:05 am

You can connect using telnet/ssh via USB...
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4082
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: 0.8.1-beta release hangs at start menu

Postby yoshio » Fri Apr 25, 2014 9:59 am

Thank you !!

I created the environment again with
ejre-7u55-fcs-b13-linux-arm-sflt-headless-17_mar_2014.tar.gz.

As a result, I could success to install.

Best Regards.
Yoshio.
yoshio
New User
 
Posts: 3
Joined: Tue Apr 22, 2014 8:05 am

Re: 0.8.1-beta release hangs at start menu

Postby dfamil » Fri May 23, 2014 11:32 pm

hi

well finally sucess. here is what i did after trying everything that was on the site.
reverted to EV3 to fw 1.03h was fw1.05h not sure if fw 1.06h will work.

reformated sd card on mac couldn't figured out how to collapse partitions on a PC.

used sd formatter https://www.sdcard.org/downloads/formatter_4/
    on PC there is one on the mac also, didn't try. had tried to format using disk utility only didn't work.

    used jre 51 jre 55 did not work.

    that did the trick!!!!
    dfamil
    New User
     
    Posts: 14
    Joined: Mon Aug 05, 2013 3:28 pm

    Re: 0.8.1-beta release hangs at start menu

    Postby qus » Thu Sep 18, 2014 8:54 am

    It seems the problem presists. Following suggestions in all previous posts didn't get me beyond "Starging menu". Reformatted and installed multiple times. Each time installs OK, reboots, starts EV3 and then freezes at "Starting menu". Tried with 51, 55 and latest Java versions. Any more suggestions?
    qus
    New User
     
    Posts: 12
    Joined: Wed Jul 17, 2013 6:24 am

    Next

    Return to EV3 Software

    Who is online

    Users browsing this forum: tzrfl8 and 1 guest

    more stuff