0.8.1 Mac OS 10.9.2 installation problem

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

0.8.1 Mac OS 10.9.2 installation problem

Postby esmetaman » Mon Apr 21, 2014 10:10 pm

Hi Mates,

recently, I started to use a Mac to develop with LeJOS and today I tried to install LeJOS 0.8.1 but when I execute the shell scripts in the path:

Code: Select all
leJOS_EV3_0.8.1-beta/bin/


I receive the following message:

Code: Select all
Error: This Java instance does not support a 32-bit JVM.
Please install the desired version.


The JVM installed in the system is:

Code: Select all
java version "1.7.0_51"
Java(TM) SE Runtime Environment (build 1.7.0_51-b13)
Java HotSpot(TM) 64-Bit Server VM (build 24.51-b03, mixed mode)


So I am not sure what is the problem.

Many thanks in advance.

Cheers

Juan Antonio
Juan Antonio Breña Moral
http://www.juanantonio.info/lejos-ebook/
http://www.iloveneutrinos.com/
User avatar
esmetaman
Advanced Member
 
Posts: 290
Joined: Wed Sep 13, 2006 12:16 am
Location: Madrid, Spain

Re: 0.8.1 Mac OS 10.9.2 installation problem

Postby lawrie » Tue Apr 22, 2014 7:30 am

The commands still use -d32 for MAC OSX (if uname is Darwin), as I have not changed the script templates from the NXT versions. Perhaps it is not necessary for the EV3.
You can edit the scripts to remove $EV3_FORCE32.
lawrie
leJOS Team Member
 
Posts: 922
Joined: Mon Feb 05, 2007 1:27 pm

Re: 0.8.1 Mac OS 10.9.2 installation problem [SOLVED]

Postby esmetaman » Tue Apr 22, 2014 9:55 pm

Hi Lawrie,

it is correct, I updated the script with your notes and now, I can continue with the installation.

Previous:

Code: Select all
"$JAVA" $EV3_FORCE32 "-DEV3.home=$EV3_HOME" "-DCOMMAND_NAME=$EV3_COMMAND" -classpath "$EV3_CP_PC" lejos.ev3.tools.EV3SDCard  "$@"


Current:

Code: Select all
"$JAVA" "-DEV3.home=$EV3_HOME" "-DCOMMAND_NAME=$EV3_COMMAND" -classpath "$EV3_CP_PC" lejos.ev3.tools.EV3SDCard  "$@"


Many thanks Lawrie.

Cheers
Juan Antonio Breña Moral
http://www.juanantonio.info/lejos-ebook/
http://www.iloveneutrinos.com/
User avatar
esmetaman
Advanced Member
 
Posts: 290
Joined: Wed Sep 13, 2006 12:16 am
Location: Madrid, Spain

Re: 0.8.1 Mac OS 10.9.2 installation problem

Postby Programus » Sat Apr 26, 2014 9:22 am

I just fixed this problem using the same way.

But my problem is why I cannot start EV3Control from eclipse plugin button?
After I clicked the [Starts the EV3Control GUI tool] button which have a leJOS icon from the eclipse toolbar. "EV3Control has been started successfully" was displayed in the console view of eclipse.
But nothing happened. Even after I modified the shell script and I can start EV3Control from command line without problem.

Of course I have set the directory I extract the files which is also the parent directory of bin\ as EV3Home in eclipse.

Is there any advice?
User avatar
Programus
Novice
 
Posts: 34
Joined: Fri Sep 18, 2009 1:43 pm
Location: China

Re: 0.8.1 Mac OS 10.9.2 installation problem

Postby lawrie » Sat Apr 26, 2014 6:59 pm

Its probably the same problem as the shell script. The Eclipse plugin is probably passing a -d32 flag. I will investigate.
lawrie
leJOS Team Member
 
Posts: 922
Joined: Mon Feb 05, 2007 1:27 pm

Re: 0.8.1 Mac OS 10.9.2 installation problem

Postby Programus » Sat Apr 26, 2014 10:48 pm

lawrie wrote:Its probably the same problem as the shell script. The Eclipse plugin is probably passing a -d32 flag. I will investigate.


Do you mean that the eclipse plugin use its own command instead of simply invoke the shell script, don't you?
User avatar
Programus
Novice
 
Posts: 34
Joined: Fri Sep 18, 2009 1:43 pm
Location: China


Return to EV3 Software

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

more stuff