Downloading firmware

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

Downloading firmware

Postby tarlan_bakirli » Sun May 04, 2014 10:18 am

Hi. I have installed EV3 Eclipse plugin and set EV3 Home path. But now I can't upload firmware to the EV3 brick. How can I upload it?
tarlan_bakirli
New User
 
Posts: 1
Joined: Wed Apr 23, 2014 11:36 am

Re: Downloading firmware

Postby gloomyandy » Sun May 04, 2014 1:52 pm

Are you following the instructions on the leJOS wiki?
http://sourceforge.net/p/lejos/wiki/Get ... JOS%20EV3/
If so you will know that you need to create an SD card for the EV3 to boot leJOS from. There is no way to "download the firmware" from eclipse. If you are still having problems please make sure you tell us what operating system you are using, what you have done exactly and what happens. The more detail you provide the more likely it is that you will get help.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4013
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Downloading firmware

Postby jackhogan11 » Fri Jun 13, 2014 9:33 pm

I CANNOT get EV3 to work with 8.1 beta lejos. (I have Windows 8 ).

I downloaded the JDK, the LEJOS 8.1 Beta, the Java 7 version of the oracle file and Eclipse.

Eclipse seems to be working. I was able to import the sample EV3 project. I am not sure if it needs to be in a special directory.

When I set up my microSD card, which is a sandisk 16GB that I ran format from the file explorer. I brought over the zip file and copied the zip file and unzipped it. That didn't seem to bring the files to the root directory so I moved the extracted files to the root. Then I brought over the .gz file. I have a netgear n150 dongle.

When I try to boot the ev3 the keypad goes red and the screen just says "Starting". I left it for an hour and it never changed. I tried booting while connected via USB it did the same thing.

I do not have a lot of experience with Java, I am 10 years old. I would really appreciate any advice as I have been working on this for about 5 hours already and I cant get it to work.
PLEASE HELP!

Jack
jackhogan11
New User
 
Posts: 10
Joined: Thu Jun 12, 2014 12:50 am

Re: Downloading firmware

Postby gloomyandy » Fri Jun 13, 2014 9:57 pm

Hi Jack,firstly welcome to the forum and leJOS. Secondly please do not post the same question to multiple threads, if people can help they will, asking again and again will not help.

Back to your problem. What is actually displayed on the EV3 screen, does it mention leJOS at all, or just Mindstorms? It sounds like there may be a problem with the way your sd card is formatted, or possibly the sd card itself. How did you create your sd card image, the best way is probably to use the leJOS Windows installer to do this rather than copying the files by hand. If you are still having problems you may need to to reformat your card, I would recommend that you use the following program to do this:
https://www.sdcard.org/downloads/formatter_4/
leJOS is still a rather complex system to get working on the EV3, we are trying to make it easier but there is still work to do.

Good luck

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4013
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Downloading firmware

Postby jackhogan11 » Sat Jun 14, 2014 12:46 am

Hi Andy,

Thank you for the recommendation, I tried it but it didn't work.

I am going to buy another micro SD/SDHC card and adapter.

Is there one you would recommend?

Jack
jackhogan11
New User
 
Posts: 10
Joined: Thu Jun 12, 2014 12:50 am

Re: Downloading firmware

Postby gloomyandy » Sat Jun 14, 2014 7:32 am

Jack before you buy another card, what installer did you use? Did you reformat the card using the program I recommended? Did you get any errors from either the leJOS installer or from the format? What happens hen you try and boot the card, what exactly is displayed on the screen and does the EV3 ever start up. Finally what firmware do you have installed on our EV3, is is the standard Lego firmware, what version is it?

The more information you provide the more likely it is that we can help you.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4013
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Downloading firmware

Postby jackhogan11 » Sat Jun 14, 2014 3:02 pm

I used the installer that comes from the leJOS win32 setup.

I did but it didn't work.

No errors from the SD card creator.

It says on the screen:
MINDSTORMS
----------------------------
Starting...

I had the firmware that came from the EV3 Cube Stormer (V1.05M).
jackhogan11
New User
 
Posts: 10
Joined: Thu Jun 12, 2014 12:50 am

Re: Downloading firmware

Postby gloomyandy » Sat Jun 14, 2014 4:33 pm

Please install the standard Lego firmware, you will not be able to install and boot leJOS with the "enhanced" firmware installed. If you search the forums you will see that a number of users have reported a similar issue.
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4013
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Downloading firmware

Postby jackhogan11 » Sat Jun 14, 2014 9:39 pm

It WORKED!
Thank you so much for helping me.

Jack
jackhogan11
New User
 
Posts: 10
Joined: Thu Jun 12, 2014 12:50 am


Return to EV3 Software

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff