I2C Devic tester in nxjcontrol broken?

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

I2C Devic tester in nxjcontrol broken?

Postby s.frings » Sun Jan 08, 2012 4:25 pm

Could it be possible that the I2C Device tester does not work at all? I tried it with four self-made I2C devices that all work fine in Java but do not respond in nxjcontrol. Any ideas?
s.frings
Active User
 
Posts: 131
Joined: Tue Jul 20, 2010 2:01 pm

Re: I2C Devic tester in nxjcontrol broken?

Postby gloomyandy » Sun Jan 08, 2012 6:21 pm

Hi,
When you say they work fine in Java, do you mean if you write a program that runs on the NXT? Can you post the code you are using to test the devices on the NXT. What i2c address do your sensors use? I have a feeling that nxjcontrol only uses the default address 0x2...

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4042
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: I2C Devic tester in nxjcontrol broken?

Postby skoehler » Sun Jan 08, 2012 6:36 pm

gloomyandy wrote:Hi,
When you say they work fine in Java, do you mean if you write a program that runs on the NXT? Can you post the code you are using to test the devices on the NXT. What i2c address do your sensors use? I have a feeling that nxjcontrol only uses the default address 0x2...


The default address seems to be 1 which is completely wrong.
Update: no, the GUI shows one, but internally the address is overwritten with 0x02 - always. Fixed that:
http://lejos.svn.sourceforge.net/viewvc ... 19&r2=6151
skoehler
leJOS Team Member
 
Posts: 1418
Joined: Thu Oct 30, 2008 4:54 pm

Re: I2C Devic tester in nxjcontrol broken?

Postby s.frings » Mon Jan 09, 2012 3:46 pm

Ah, ok. That explains why I was not able to get any answer from my I2C devices.
s.frings
Active User
 
Posts: 131
Joined: Tue Jul 20, 2010 2:01 pm


Return to NXJ Software

Who is online

Users browsing this forum: No registered users and 3 guests

more stuff