Bluetooth Connection; NXT to Laptop

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

Bluetooth Connection; NXT to Laptop

Postby Jochi » Wed Jan 16, 2008 3:14 pm

Hi There,

I am trying to connect my NXT to my laptop over Bluetooth for a University project. I have followed all the steps in the Maximum NXT book but I'm still stuck.

I have the original NXT firmware installed and go through the steps to find my laptop. The brick sees the laptop but when I try to connect I just get the error 'line busy'. As far as I can tell my dongle is configured correctly, and each device can see each other. They just won't connect.

The book mentions connecting to the NXT from the lego software, but this does not work either. Ultimately I want to use iCommand to control the robot remotely, but obviously I need to get the brick to pair with the laptop first.

I have googled endlessly and searched all through this forum unsuccessfully. I have tried all obvious fixes that I can think of and yes all things bluetooth related are switched on and visible. My phones bluetooth is switched off to avoid any conflicts there also.

Can anyone help? If I have missed a post that might solve this problem then please point me in that direction.

Thanks,
Jochi (stressed student! ) :?
User avatar
Jochi
Novice
 
Posts: 26
Joined: Tue Nov 06, 2007 8:17 pm
Location: Guildford, UK

Postby roger » Thu Jan 17, 2008 4:34 am

Hi Jochi,
Seems likely that the problem is with the PC. Did the paring described on pg 147 work as described?
Roger
roger
Moderator
 
Posts: 359
Joined: Fri Jun 01, 2007 4:31 am
Location: Berkeley, CA

Postby Jochi » Sun Jan 20, 2008 12:28 pm

roger wrote:Hi Jochi,
Seems likely that the problem is with the PC. Did the paring described on pg 147 work as described?
Roger


Hi Roger,

The steps on page 147 did not work originally. I kept receiving 'line busy' on the brick. However I have now managed to pair the devices. Unfortunatly I'm not quite sure what I did to solve the problem. Just after attempting to connect the two together for the umpteenth time it worked!

Thanks for your help :)
User avatar
Jochi
Novice
 
Posts: 26
Joined: Tue Nov 06, 2007 8:17 pm
Location: Guildford, UK


Return to NXJ Software

Who is online

Users browsing this forum: No registered users and 2 guests

more stuff