[Problem] Lejos Crashing on startup

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

[Problem] Lejos Crashing on startup

Postby Bseddon » Wed Jan 16, 2008 9:36 pm

Hi Everyone

I have just installed NXJ 0.5 beta. Then when I start up the NXT I see the LEJOS logo and then the NXT goes blank without warning. I don't know what is happining. Please Help.

Thank you.

Bseddon
Bseddon
New User
 
Posts: 9
Joined: Tue Dec 18, 2007 8:47 pm
Location: UK, Surry, Staines

Postby roger » Wed Jan 16, 2008 11:58 pm

If you have not already done so, you might try removing and replacing the battery ; also flash the firmware again.
Good luck,
Roger
roger
Moderator
 
Posts: 368
Joined: Fri Jun 01, 2007 4:31 am
Location: Berkeley, CA

Postby Bseddon » Thu Jan 17, 2008 7:02 pm

Dear Roger

I've tried the things you have said (I may not have done them correctly) but I am still having the problem that after starting up the screen goes blank.


Thank you

Bseddon
Bseddon
New User
 
Posts: 9
Joined: Tue Dec 18, 2007 8:47 pm
Location: UK, Surry, Staines

Postby kirkpthompson » Thu Jan 17, 2008 7:50 pm

Maybe your code is running but not the way you expect...

Try to use LCD.drawString at strategic places in your code to output something to the LCD as a debugging aid.

-K

ADDEDNUM: Maybe I need to read more carefully :oops: I now see that it happens immediately after startup. Nevermind...
User avatar
kirkpthompson
leJOS Team Member
 
Posts: 304
Joined: Wed Dec 05, 2007 1:27 am
Location: New Mexico, USA

Postby Bseddon » Fri Jan 18, 2008 4:01 pm

Dear kirkthompson

I can't even see the nxj menu so it is not my code
Bseddon
New User
 
Posts: 9
Joined: Tue Dec 18, 2007 8:47 pm
Location: UK, Surry, Staines

Postby gloomyandy » Fri Jan 18, 2008 5:45 pm

A few things to try...
1 Can you provide more details of what you are doing to flash the nxt (So what OS, what happens when you flash the nxt). Have you been running an older version of leJOS, or is this the first time you have tried it?
2. Can you reflash the Lego code and then try leJOS again.
3. leJOS may be running there may just be a problem with the display, so try the following after you have turned on the device and have a blank screen.
a) Press the Orange key and the square gray key at the same time. Does anything happen to the display (like does it flash a little).
b) If you are using windows unplug/plug the USB cable do you get any notification sounds from Windows?
c) Try to download a program. What happens?

Good luck!

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4239
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby Bseddon » Fri Jan 18, 2008 6:28 pm

Dear gloomyandy

I don't really know what flash does and how to do it. This is the second time i am using LEJOS, before I had 0.4 beta. I am using Xp Home. I don't know how to upload the lego firmware again because my lego program does not reconize my NXT. I have tried to flash about 5 times (but I may have done it wrong). The screen does not flash when I press the orange and tha gray buttons at the same time. I also don't get a noise from windows when I disconnect the USB cable. When I try to Download a program Eclipce shows
leJOS NXJ> Linking...
leJOS NXJ> Uploading...
error BluetoothStack not detected
com.intel.bluetooth.BlueCoveImpl.<init>(BlueCoveImpl.java:136)
an error occurred: Bluetooth stack not detected

I don't use BLUETOOTH.

Thanks for your help Andy
Bseddon
New User
 
Posts: 9
Joined: Tue Dec 18, 2007 8:47 pm
Location: UK, Surry, Staines

Postby lawrie » Sat Jan 19, 2008 8:27 pm

Try doing a long reset of your NXT - press the reset button for 4 seconds. Check that you hear the pulsing noise from your NXT. Press the Orange button if you don't hear this at first.

Then see if Windows recognizes it as a USB device - it should make a noise when you connect and disconnect it and an entry should appear in Control Panel > System > Hardware > Device Manager. It should appear under Lego Devices as LEGO MINDSTORMS NXT Firmware Update Mode.

If this does not work, your NXT is not resetting. Try it again until it works pressing the Orange button to turn the NXT on first.

Once you have the NXT in firmware update mode, the Lego software should allow you to reflash the standard LEGO firmware, or you can try flashing leJOS again.

Make sure you are using a clean install of version 0.5 of leJOS and not an updated 0.4 installation.
lawrie
leJOS Team Member
 
Posts: 934
Joined: Mon Feb 05, 2007 1:27 pm

Postby Bseddon » Sun Jan 20, 2008 10:19 am

Dear lawrie

I have my NXT in firmware upload mode, but my NXT's beeping stops after a few seconds. The computer found my NXT sp I tried reflashing the NXT-G firmware. The lego software said that it was downloading the firmware, then a alert comes up saying that there are communication erorr's with the NXT. After that lego has never reconized my NXT again.

Thank you
Bseddon
New User
 
Posts: 9
Joined: Tue Dec 18, 2007 8:47 pm
Location: UK, Surry, Staines

Postby kirkpthompson » Sun Jan 20, 2008 7:17 pm

Hi. Did you make sure you have fresh batteries?
User avatar
kirkpthompson
leJOS Team Member
 
Posts: 304
Joined: Wed Dec 05, 2007 1:27 am
Location: New Mexico, USA


Return to NXJ Software

Who is online

Users browsing this forum: No registered users and 3 guests

more stuff