Insufficient parameters in nxjlink.bat

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

Insufficient parameters in nxjlink.bat

Postby jmernin » Fri Jan 18, 2008 12:05 am

I've been trying to use the nxjlink.bat script to link some of the sample programs and it looks to me like it is missing some parameters in the call to the java command that it uses.

If you take the HelloWorld sample code and build it using Ant, it seems to use a "-o HelloWorld.nxj" at the end. However, the nxjlink.bat scripts does not do this and you have to supply it on the call to nxjlink.bat

Interestingly, if I use the command "nxjlink HelloWorld" (without the -o HelloWorld.nxj), my PC goes bananas and beeps uncontrollably for around 30 seconds (very annoying)
jmernin
New User
 
Posts: 23
Joined: Thu Jan 17, 2008 11:52 pm

Postby lawrie » Fri Jan 18, 2008 12:55 am

The -o parameter is mandatory on nxjlink and this really should be checked by the script. If you do not provide the -o parameter it sends the binary program to the terminal. Most people use the nxj script which links and downloads.
lawrie
leJOS Team Member
 
Posts: 929
Joined: Mon Feb 05, 2007 1:27 pm

Postby jediknightkrazy » Fri Jan 18, 2008 2:07 am

I am having a similar problem:
Both nxj and nxjbrowse (with arguments) return the same text as a "java" (no arguments) call. Are there updated .bat files to download?
I'm a geek.
jediknightkrazy
New User
 
Posts: 5
Joined: Wed Jan 16, 2008 10:40 pm

Postby lawrie » Sat Jan 19, 2008 8:50 pm

No, there are not any updated .bat files.

Remove the "@echo off" line from nxj.bat and see what is going wrong. If you cannot see a problem, post the output you get on this forum.
lawrie
leJOS Team Member
 
Posts: 929
Joined: Mon Feb 05, 2007 1:27 pm

Postby jmernin » Sun Jan 20, 2008 9:16 pm

Thanks for the original reply Lawrie,

I guess I do see myself using the nxj.bat script most of the time but was still curious to know if there was something else I was doing wrong with my use of the nxjlink.bat script. Clearly, there was not.

Turning on the echo is definitely worth doing when you are using the software for the first time (like me), especially if you are doing so from something like Eclipse.
jmernin
New User
 
Posts: 23
Joined: Thu Jan 17, 2008 11:52 pm


Return to NXJ Software

Who is online

Users browsing this forum: Google [Bot] and 2 guests

more stuff