no jlibnxt in java.library.path (OS X 10.4)

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

no jlibnxt in java.library.path (OS X 10.4)

Postby bscardin » Mon Jan 28, 2008 2:14 am

I am trying to get things up and running on my MacBook. I downloaded the 0.5 lejos software and things were going along great for a while. The only manual modifications I had made was to copy the jni.h and jni_md.h from the Java JDK folder into the libnxt folder. With that done things compiled great. I was able to run nxjflash fine and the brick appears to be loaded with the lejos firmware.

Now, the problem is when I try to load a program onto the NXT using nxj. I am trying to load the Tune sample using nxj -r Tune and I get the following:

Code: Select all
leJOS NXJ> Linking...
leJOS NXJ> Uploading...
leJOS NXJ> no jlibnxt in java.library.path
leJOS NXJ> no jbluez in java.library.path


I have the following environment variables set right now:

Code: Select all
export LEJOS_HOME=/Users/ben/lejos_nxj
export JAVA_HOME=/Library/Java/Home
export NXJ_HOME=/Users/ben/lejos_nxj/
export PATH=/Users/ben/lejos_nxj/bin:/sw/bin:/sw/sbin:/usr/local/bin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/X11R6/bin


Any ideas? It feels like I am so close to getting this to work but I have searched and searched and not found an answer to this specific issue.

Thanks in advance for any help.
bscardin
New User
 
Posts: 5
Joined: Mon Jan 28, 2008 1:34 am

One more thing...

Postby bscardin » Mon Jan 28, 2008 2:24 am

I forgot to add that there is a libjlibnxt.dylib file in the lejos_nxj/bin directory. Seemed to compile fine during the main build process.
bscardin
New User
 
Posts: 5
Joined: Mon Jan 28, 2008 1:34 am


Return to NXJ Software

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 3 guests

more stuff