NXJ is ticking and can't power on

This is where you talk about the NXJ hardware related topics such as the brick, sensors, LEGO pieces, etc.

Moderators: 99jonathan, roger, imaqine

NXJ is ticking and can't power on

Postby DOMH » Thu Dec 04, 2008 3:15 pm

Hello,

I has wanted to flash my NXJ, but, I think, after a bad manipulation, the NXJ can't power on.

Now, it is ticking and when I reset it (with the button behind the NXT), it stop like 4 seconds and restart ticking ...
Nut nothing on the screen !

What is the problem ?



P.S. : Sorry for my english, I'm french.
DOMH
New User
 
Posts: 5
Joined: Tue Nov 18, 2008 5:26 pm

Postby gloomyandy » Thu Dec 04, 2008 4:56 pm

It is in firmware download mode (sometimes called SAMBA mode). Try removing the battery for a few seconds, if that does not work, re-flash the firmware....

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

NXJ is ticking and can't power on

Postby Evertjelle » Sun Mar 21, 2010 3:22 pm

I got that problem too!!!! :cry:
PLease tell my how to fix it!
There is also nothing on the screen, He stays ticking if i push a button, after a few minutes he stops ticking but when i press a button he starts again

Please help me!!!! :!: :!: :!: :!: :!: :!:
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Postby gloomyandy » Sun Mar 21, 2010 3:31 pm

As I said above the NXT is in firmware download mode you just need to re-download the firmware you can do this using the leJOS command nxjflash or you can use the standard Lego software (simply use Tools->update firmware)...

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Doesn't work

Postby Evertjelle » Mon Mar 22, 2010 4:03 pm

The mindstorms is ticking, he is connected via USB, My computer 'sees' him with the name 'GPS Camera Detect' and I try Nxjflashg..

That doesn't work!
He just stays ticking!
-if i try to download LeJos firmware again (Nxjflashg) the program fails with the error :

Bad news: An error has occurred lejos.pc.comm.NXTCommException: Cannot load a comm driver


-if i try to restore lego firmware, he just find no mindstorms

-I have tried other USB ports too, but, same result.

-I have tried Nxjflash too, he fails with the same error.




PLEASE HELP ME!!!!!
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Postby gloomyandy » Mon Mar 22, 2010 5:10 pm

First step, you must get to the stage of being able to re-flash the standard Lego firmware using the standard Lego NXT-G software. If you can't get that to work you will not get leJOS to work. So get that fixed, then we can help you getting leJOS working...
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby Evertjelle » Wed Mar 24, 2010 4:22 pm

OK, but how to get Mindstorms NXT in that stage?

PS: Thanks for quick response
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Postby gloomyandy » Wed Mar 24, 2010 4:59 pm

See my post two before this one... You need the standard Lego software installed on your PC. The you run it and use the tools menu and choose the update NXT firmware item...

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby Evertjelle » Wed Mar 24, 2010 5:24 pm

I now: I have the mindstorms original software and i did try to restore original firmware but that doesn't give any result! He just doesn't find a mindstorms!
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Postby gloomyandy » Wed Mar 24, 2010 8:30 pm

Well as I said first you have to fix that problem. If you are using the Lego software then it should just work. Are you sure that you have the latest drivers installed?

You have told us virtually nothing about the system you are using what is it (PC? Mac) and what operating system (Windows XP, Windows Vista, Windows 7 64bit 32 bit?). Also which version of the Lego software are you using (1.0, 1.1 2.0)? To get the Lego software working properly you may want to contact Lego for help or try posting on one of the Lego forums like this one...
http://forums.nxtasy.org/index.php?showforum=3

Really until you have the standard Lego software working on your PC there is no point in trying to make leJOS work with it...

Andy
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Postby Evertjelle » Fri Mar 26, 2010 1:17 pm

My computer is windows 7 32bit, NXT-G version is 1.0 and it is working perfectly. I have tried to install new driver and update firmware again, but same result. I am now reloading my batteries because i found on the forum NXTasy that low batteries could be the problem...
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

fixed (not by LeJos or an other forum, by LEGO )

Postby Evertjelle » Mon Mar 29, 2010 2:17 pm

I've send a mail to Lego, they gonna bring me a new NXT. (Lego service is great!!!!)
Everywhere i ask this question 'why is my NXT ticking?' I get the same answers but nobody can fix my problem. The problem is this


The mindstorms is ticking, he is connected via USB, My computer 'sees' him with the name 'GPS Camera Detect' and I try Nxjflashg..




so I think that if your mindstorms is ticking and your computers displays a weird name, just update firmware again or reset the NXT Brick, that won't help!!!

UPDATING FIRMWARE IS VERY RISKY!!!
Evertjelle
New User
 
Posts: 8
Joined: Sun Mar 21, 2010 3:17 pm

Postby gloomyandy » Mon Mar 29, 2010 2:54 pm

Well I bet that the new NXT will make no difference what so ever (except that you will have the Lego firmware already installed). Looks to me like you have a driver for some other device that is (incorrectly) recognizing the NXT in boot mode. I bet if you had a clean install of Windows with just the Lego software installed then it would work fine... If you have access to another computer you could try that... Or you could try disabling the driver for the USB camera...
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3642
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

I have same

Postby doyajii1 » Mon Jun 14, 2010 8:05 pm

I have same problem
AND I have exact same computer setting
I also seen GPS Camera detect...
I guess I have to request new NXT?
where did you request?
doyajii1
New User
 
Posts: 8
Joined: Mon Jun 14, 2010 8:03 pm

So I called company

Postby doyajii1 » Mon Jun 14, 2010 8:31 pm

I called company, and this was the instruction
and I was able to get it run mindstorm again.

1. find another computer that didn't install lejos before
2. install mindstrom software if the computer you found don't have one
3. boot up the software
4. connect the brick that you have problem to computer
5. wait till computer understand your device
6. goto tools > update NXT firmware
7. make sure LEGO MINDSTORMS NXT Firmware vX.XX is selected
and highlighted as orange
8. press download button
9. should see nxt mindstorm firmware up and running again.

I was about to say...man..XXXXXXXXX
also, I was trying to install lejos again.
However, I countered same problem again.
I think it's windows 7...I will try on windwos vista and
windows xp computer again and see what happens

I have tested and find out that somehow,,
When I was working on the windows 7 computer,
lejos nxt head was found as some gps camera.

It worked find with windows vista, for reset to mindstorm
and program with lejos.
doyajii1
New User
 
Posts: 8
Joined: Mon Jun 14, 2010 8:03 pm

Next

Return to NXJ Hardware

Who is online

Users browsing this forum: No registered users and 0 guests

more stuff