Problems installing LEJOS for RCX...new problem

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

Problems installing LEJOS for RCX...new problem

Postby gj15987 » Mon Jan 22, 2007 1:56 pm

I am following this tutorial http://lejos.sourceforge.net/p_technolo ... win32.html
for setting up LEJOS for the RCX on windows xp.

Once the firmware has transfered onto the RCX, i get the following:
Unlocking Firmware
Unlock firmware failed: Tower error: no response from RCX

When I try to comile the first program on that page I get:
javac: invalid flag

Any ideas?
Thanks.
gj15987
New User
 
Posts: 3
Joined: Mon Jan 22, 2007 1:52 pm

Postby bbagnall » Mon Jan 22, 2007 10:12 pm

You need to keep the tower in a dark area away from sunlight when uploading, or away from other lights that might interfere. A distance of about 6 inches is optimal from tower to RCX. Give it a few more tries and it should work.
User avatar
bbagnall
Site Admin
 
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm

Postby gj15987 » Tue Jan 23, 2007 2:36 pm

I've messed around with the paths n stuff a little and everything compiles and runs fine now. It still said can't unlock firmware when i put that on but it seems to work fine.

Thanks.
gj15987
New User
 
Posts: 3
Joined: Mon Jan 22, 2007 1:52 pm

Postby bbagnall » Sun Jan 28, 2007 5:24 pm

I had the same thing happen last time I tried it in April 2006. If you are using lejosfirmdl with the -f option, try it without. The fast mode can be unreliable.
User avatar
bbagnall
Site Admin
 
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm


Return to RCX Software

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff