color sensor flashing

This is where you talk about the NXJ hardware related topics such as the brick, sensors, LEGO pieces, etc.

Moderators: 99jonathan, roger, imaqine

color sensor flashing

Postby vyse » Wed Mar 23, 2011 2:09 pm

Hi,

I have a 4 color sensors. All work in the original firmware.

If I use the LeJos firmware (0.85), only work 2, the other two flashing constantly.

I have tested with ColorSensorTest.

What is the problem?

Thanks
vyse
New User
 
Posts: 6
Joined: Wed Mar 23, 2011 2:01 pm

Re: color sensor flashing

Postby gloomyandy » Wed Mar 23, 2011 2:32 pm

What do you mean by they don't work? Do you get readings from them? Do you have the updated classes.jar? Are you testing them one at a time?

See this thread for the updated classes.jar and how to install it...
viewtopic.php?f=7&t=1883&p=12684&hilit=classes.jar+color+sensor#p12684
User avatar
gloomyandy
leJOS Team Member
 
Posts: 4084
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: color sensor flashing

Postby vyse » Wed Mar 23, 2011 3:47 pm

What do you mean by they don't work? Do you get readings from them? Do you have the updated classes.jar? Are you testing them one at a time?


I have tested the sensor with projects/samples/ColorSensorTest/ColorSensorTest.java

Example, If i select "color mode: blue" the blue lights is blinking, and I read -1. This happens in all colors ( and mode full)

This only happens on two sensors

This sensors work fine in original firmware.

See this thread for the updated classes.jar and how to install it...
viewtopic.php?f=7&t=1883&p=12684&hilit=classes.jar+color+sensor#p12684


This works

thanks
vyse
New User
 
Posts: 6
Joined: Wed Mar 23, 2011 2:01 pm


Return to NXJ Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

more stuff