NXTway-GS problem based on OSEK procedure

Post your NXJ projects, project ideas, etc here!

Moderators: 99jonathan, roger, imaqine

NXTway-GS problem based on OSEK procedure

Postby wizeguyme » Sat May 28, 2011 6:28 pm

hi i'm working on the project NXTway-gs following the intructions on http://lejos-osek.sourceforge.net/ , after following the instructions of installation and upload i successfuly uploaded the code by ./rxeflash.sh command after makng NXTway_GS_OSEK.rxe in cygwin by 'make all' command but my program which was in c:/cygwin/nxtOSEK/samples_c/nxtway_gs directory is not balancing the segway and neither is gamepad controling its movements, my segway tries to balance itself in the begining if u put it on ground but then after a while its wheels start move in 1 direction and does not move backward or forward if i move the robot and change angle, im using nxt kit standard tires, am i supose to make any changings in code? and need to upload extra code for gamepad....plz help it's more than a month im stuck at it first in installation of cygwin n uploading th code but that problem was solved, but this new problem doesnt seem to go away...my target was to control its movement by joystick but even it is not balancing the gamepad doesnt either seem to moving or changing the speed of the motors i.e doing anything, thou i see th [BT] on screen..it was a big msg i wanted explain as many things as i could to make u understand...it would be kind for any of u to help
|A|r|S|a|L|a|N|
wizeguyme
New User
 
Posts: 2
Joined: Tue Jul 13, 2010 11:55 am
Location: Pakistan

Re: NXTway-GS problem based on OSEK procedure

Postby bullestock » Tue May 31, 2011 11:22 am

wizeguyme wrote:it was a big msg i wanted explain as many things as i could to make u understand

Next time, try putting a few line breaks in there.
bullestock
New User
 
Posts: 14
Joined: Fri Mar 04, 2011 9:52 pm


Return to NXJ Projects

Who is online

Users browsing this forum: No registered users and 5 guests

cron
more stuff