Writing programs for the EV3

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

Re: Writing programs for the EV3

Postby gloomyandy » Fri Sep 20, 2013 5:07 pm

Hmm that's all a little strange. Have you changed any of the default settings that come with eclipse? What version of eclipse did you install. Normally eclipse will build your programs (I assume you have actually saved the program source file?), automatically.

Other than that sorry can't really help. I know the steps that I described worked with the versions of things I used as I started from a totally clean system when writing the wiki page.

Perhaps someone else may have some idea as to what is going wrong....
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3645
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Writing programs for the EV3

Postby lmcdaniel » Fri Sep 20, 2013 5:11 pm

gloomyandy wrote:Have you changed any of the default settings that come with eclipse? What version of eclipse did you install.


No, I did a fresh install earlier this morning and I followed the instructions to the letter, well almost, since I am running Windows. I am running Kepler Eclipse 4.3. Once I get the virtual box set up I'll try again, this time in Linux.

Thanks for your help.
lmcdaniel
New User
 
Posts: 8
Joined: Sun Sep 08, 2013 10:37 pm

Re: Writing programs for the EV3

Postby gloomyandy » Fri Sep 20, 2013 6:15 pm

You may want to search your system to see if the class files are being created anywhere at all. Which eclipse package did you choose? I assume it was the simple java developer one, not anything else (like the enterprise options)?
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3645
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Writing programs for the EV3

Postby skoehler » Fri Sep 20, 2013 7:10 pm

Aswin had a similar problem. The problem was, that the buildpath of the ev3classes project was incomplete (Eclipse didn't find jna.jar at the specified path). Eclipse is not able to build the project in that case. It also keeps all projects from building, that have ev3classes a project dependency.
skoehler
leJOS Team Member
 
Posts: 1350
Joined: Thu Oct 30, 2008 4:54 pm

Re: Writing programs for the EV3

Postby leJosNeedHelp » Tue Sep 24, 2013 7:43 am

Hey guys,

are there any solutions for the problem of Imcdaniel ?
Because i've the same problem and i've tried everything...but it doesnt work.
I would be pleased if someone can help me !

Greetz from Germany :wink:
leJosNeedHelp
New User
 
Posts: 18
Joined: Tue Sep 24, 2013 7:33 am

Re: Writing programs for the EV3

Postby skoehler » Tue Sep 24, 2013 7:56 am

Yes of course. In case you're facing the same project, you have to edit the build path of the ev3classes project and point eclipse at an existing copy of jna.jar.
skoehler
leJOS Team Member
 
Posts: 1350
Joined: Thu Oct 30, 2008 4:54 pm

Re: Writing programs for the EV3

Postby ruperty » Fri Dec 13, 2013 4:51 pm

I have the same problem with EV3FirstProgram building the jar. I can't see any problem with ev3classes in terms of the jna jar, looking in project properties.

Though do have red marks on the EV3FirstProgram.java file, with import lejos.nxt.Button, for example.

Where should this package be as there is no package in ev3classes called lejos.nxt?
Regards,
Rupert
ruperty
Novice
 
Posts: 71
Joined: Sun Oct 14, 2007 11:21 am

Re: Writing programs for the EV3

Postby gloomyandy » Fri Dec 13, 2013 5:12 pm

Sounds like you are trying to use an ev3calss from gitmaster not from the 0.4.0-alpha tag. There is certainly an lejos.nxt package in the ev3classes tagged as 0.4.0-aplha. read the following sticky:
viewtopic.php?f=18&t=4782
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3645
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: Writing programs for the EV3

Postby ruperty » Mon Dec 16, 2013 12:03 pm

gloomyandy wrote:Sounds like you are trying to use an ev3calss from gitmaster not from the 0.4.0-alpha tag. There is certainly an lejos.nxt package in the ev3classes tagged as 0.4.0-aplha. read the following sticky:
viewtopic.php?f=18&t=4782


Thanks, that additional tag checkout did the trick.
Regards,
Rupert
ruperty
Novice
 
Posts: 71
Joined: Sun Oct 14, 2007 11:21 am

Previous

Return to EV3 Software

Who is online

Users browsing this forum: liugoanywhere and 4 guests

more stuff