Mac OSX, RCX 1.0, firmdl gives "Tower not responding"

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

Mac OSX, RCX 1.0, firmdl gives "Tower not responding"

Postby sravet » Sat Nov 30, 2013 3:37 am

I am helping my son with his 8th grade project -- building a robot using my old RCX. I haven't used it in quite some time and have switched to Mac from PC. I followed the various tutorials and got the software to compile with a few minor changes. But now when I try to run firmdl I get this:

% firmdl
mode = slow
tty= /dev/cu.usbserial-FTDJS8F4
writelen = 4
W 0000: 10 fe 10 fe
recvlen = 0
writelen = 4
W 0000: 10 fe 10 fe
recvlen = 0
Open failed: tower not responding, errno = 60

My setup is an FTDI serial adapter plugged into a USB port on my macbook. I have verified that the adapter works by looping pin 2 to pin 3 and seeing characters echoed back in my command line serial terminal (nanokdp). I tried the same thing by looping pins 2 and 3 at the far end of the Lego serial cable, but that doesn't work. Upon probing the cable I find that pin 2 is straight through from one end to the other, but it appears that pins 3 and 4 are swapped.

looping 2 to 4 at the far end of the lego cable also does not produce an echo.

Some internet reading told me that the tower comms is 2400/8/1 with odd parity. I used these settings in my serial terminal connected to the tower but got no response. I read in some places that there should be a green LED on the tower? I don't see that either. The battery in the tower is a brand new 9V battery, and the batteries in the RCX are freshly recharged. The RCX powers up and seems functional, and is pointed at the tower at a distance of about 6 inches.

I am using Java version 1.6.
OS version is 10.8.5

Oh yeah, I also tried lejosfirmdl:

% lejosfirmdl
Use --help for options.
/Users/sravet/Documents/ravet_racing/lejos/lejos_2_1_0/bin/../bin/lejos.srec: image contains no data

I don't understand this either, because the specified srec file seems to contain plenty of data.

Anyway, my son and I would certainly appreciate some assistance getting this working for his project. Any suggestions?

thanks,
--steve
sravet
New User
 
Posts: 1
Joined: Sat Nov 30, 2013 3:10 am

Return to RCX Software

Who is online

Users browsing this forum: No registered users and 0 guests

more stuff