EV3 brick starts endlessly

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

EV3 brick starts endlessly

Postby vbelenky » Sat Dec 14, 2013 4:31 pm

I've followed the instructions at http://sourceforge.net/p/lejos/wiki/Creating%20a%20bootable%20SD%20card/. Then when I put the sdcard and dongle into the brick and start it it starts endlessly. When I remove the dongle then the leJOS screen shows up on the brick, therefore, I think that I did not configure the connection correctly. I spent more than an hour trying various things. Can you please look at my configuration and maybe point out something:

Code: Select all
network={
   ssid="YS"
   key_mgmt=WPA2-PSK
   psk="e63c651f41a18029c183cd36c32a58ba8b90f83d21d7d64ad2e929730cd91773"
   #pairwise=TKIP
   #group=CCMP TKIP
   #proto=RSN
}
vbelenky
New User
 
Posts: 18
Joined: Sun Dec 01, 2013 4:08 am

Re: EV3 brick starts endlessly

Postby gloomyandy » Sat Dec 14, 2013 7:09 pm

A few things to try...

Don't put the psk in double quotes if you are using an encoded version of the psk. If you are using a plain text version then it needs to be in quotes. How did you create the wpa_supplicant.conf file. Do not use a Windows program to create it or edit it, make sure you use a Linux editor. Why have you commented out the various crypt and other settings? What sort of authentication does your WiFi router use? What is the SSID of your router?
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3632
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK

Re: EV3 brick starts endlessly

Postby vbelenky » Sat Dec 14, 2013 8:17 pm

Finally I got it to work. Here is my configuration (note that even though my router is configured for WPA2 I removed the 2):

Code: Select all
network={
   ssid="YS"
   key_mgmt=WPA-PSK
   psk=e63c651f41a18029c183cd36c32a58ba8b90f83d21d7d64ad2e929730cd91773
   pairwise=CCMP TKIP
   group=CCMP TKIP
   proto=RSN
}
vbelenky
New User
 
Posts: 18
Joined: Sun Dec 01, 2013 4:08 am

Re: EV3 brick starts endlessly

Postby gloomyandy » Sat Dec 14, 2013 10:27 pm

I'm pretty sure that WPA2-PSK is not a valid entry. For future reference here is the man page for the conf file:
http://www.freebsd.org/cgi/man.cgi?quer ... &sektion=5
User avatar
gloomyandy
leJOS Team Member
 
Posts: 3632
Joined: Fri Sep 28, 2007 2:06 pm
Location: UK


Return to EV3 Software

Who is online

Users browsing this forum: msx and 2 guests

more stuff