message "failed to load properties file" during startup

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

message "failed to load properties file" during startup

Postby cfin » Tue Jan 28, 2014 8:31 am

Hello,
I migrated from 0.4.0 to 0.5.0. I can again start programs. That is okay. But one thing is annoying me:
At the beginn of the programm execution I get this line on system.out: "failed to load properties file" My programm runs normally after that.
I start the program using jrun directly from the shell.

Is there anything I can do against this error message?

thank you,
cfin
cfin
New User
 
Posts: 15
Joined: Fri Oct 25, 2013 8:04 pm

Re: message "failed to load properties file" during startup

Postby lawrie » Tue Jan 28, 2014 3:05 pm

You could ignore it. Various menu and other settings are kept in a settings.properties file. If that does not exist, you get the message. It should go away if you use the menu to save a setting such as the sound master volume. I will remove the message for the next release.
lawrie
leJOS Team Member
 
Posts: 934
Joined: Mon Feb 05, 2007 1:27 pm

Re: message "failed to load properties file" during startup

Postby daspfanni2000 » Tue Feb 04, 2014 8:44 pm

Praise the search function!:-)

During my first steps, I am stumbling across the same message.

If the program is only "Hello World!" to System.out. the message does not appear. If i then get the localEV3/Port, the message appears.

Code: Select all
public static void main(String[] args) {
   System.out.println("Hello World!");
   Port port = LocalEV3.get().getPort("S4"); //comment this out to not see the message
}


I know this is a very minor finding:-) Maybe this helps getting rid of the underlying problem nevertheless :wink:
daspfanni2000
New User
 
Posts: 23
Joined: Sun Dec 22, 2013 5:34 pm


Return to EV3 Software

Who is online

Users browsing this forum: No registered users and 3 guests

more stuff