First EV3 program

This is where you talk about the EV3 software itself, installation issues, and programming talk.

Moderators: roger, gloomyandy, skoehler

First EV3 program

Postby seicaratteri » Sun Feb 09, 2014 4:21 pm

Hello.

I'm developing my first ev3 program using lejos. I've successfully created a bootable SD, and configured eclipse as well.
What I have to do now, is using 'Ant build' on dbusjava and on ev3classes.
Do I need a wifi dongle? Can't I use the cable? Because it give me this error:

Code: Select all
copy:
      [scp] Connecting to 10.0.1.1:22

BUILD FAILED
C:\Users\pietro\git\ev3\DBusJava\build.xml:33: com.jcraft.jsch.JSchException: java.net.ConnectException: Connection timed out: connect


(if needed, this is the whole log:
Code: Select all
Buildfile: C:\Users\pietro\git\ev3\DBusJava\build.xml
clean:
   [delete] Deleting directory C:\Users\pietro\git\ev3\DBusJava\build
compile:
    [mkdir] Created dir: C:\Users\pietro\git\ev3\DBusJava\build
    [javac] C:\Users\pietro\git\ev3\DBusJava\build.xml:22: warning: 'includeantruntime' was not set, defaulting to build.sysclasspath=last; set to false for repeatable builds
    [javac] Compiling 109 source files to C:\Users\pietro\git\ev3\DBusJava\build
    [javac] Note: Some input files use unchecked or unsafe operations.
    [javac] Note: Recompile with -Xlint:unchecked for details.
    [javac] Creating empty C:\Users\pietro\git\ev3\DBusJava\build\lejos\internal\io\package-info.class
jar:
      [jar] Building jar: C:\Users\pietro\git\ev3\DBusJava\dbusjava.jar
copy:
      [scp] Connecting to 10.0.1.1:22

BUILD FAILED
C:\Users\pietro\git\ev3\DBusJava\build.xml:33: com.jcraft.jsch.JSchException: java.net.ConnectException: Connection timed out: connect

Total time: 37 seconds
)

Thanks in advance!
seicaratteri
New User
 
Posts: 1
Joined: Sun Feb 09, 2014 4:15 pm

Re: First EV3 program

Postby M13 » Tue Feb 11, 2014 5:00 pm

On which operating system are you? Windows ... 7, 8, XP...?

Is the EV3 brick correctly recognized as a RNDIS device when you plug it in via USB?
M13
New User
 
Posts: 4
Joined: Thu Jan 16, 2014 9:56 pm


Return to EV3 Software

Who is online

Users browsing this forum: Yahoo [Bot] and 1 guest

more stuff