problems with RCXPort

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

problems with RCXPort

Postby markino1985 » Tue Jan 29, 2008 9:51 am

hi, I've got a very big problem with the lejos plugin for eclipse. I'm trying to implement a program where the pc communicates with the RCX brick, and I've decided to use the RCXPort methods (write, read,...). When I launch the program with Lejos, appear the following error:

" leJOS link (Time of error: 29 gennaio 2008 10:45:39 GMT -01:00)
Reason:
Class Josx.rcxcomm.RCXPort (file josx.rcxcomm.RCXPort.class) not found in CLASSPATH js.tinyvm.ClassPath@d04843."

Is there anyone can help me?

Thanks
Marco

PS. Sorry for my bad english, but I'm Italian... :D
markino1985
New User
 
Posts: 1
Joined: Tue Jan 29, 2008 9:42 am

Re: problems with RCXPort

Postby mpscholz » Tue Jan 29, 2008 9:45 pm

Marco,

markino1985 wrote:hi, I've got a very big problem with the lejos plugin for eclipse.


Which leJOS Eclipse plugin for the RCX are you using (there are some different ones around for the RCX)?
Which version of Eclipse are you running?
leJOS Developer
mpscholz
New User
 
Posts: 20
Joined: Fri Jan 18, 2008 1:37 pm
Location: Germany

rcxcomm library problem

Postby Tobi89 » Fri Apr 25, 2008 6:49 pm

Hi,
first of all my name is Tobias I am new in this Forum.

I have the same proplem with RCXPort class.

I use the Eclipse plugin org.lejos.ldt_1.2.0
and Eclipse 3.2.

I hope somebody can help me

Thanks

Tobi
Tobi89
New User
 
Posts: 3
Joined: Fri Apr 25, 2008 6:37 pm
Location: Germany

Postby JavaMan » Sat Apr 26, 2008 12:00 am

Looks like something with your classpath.

I had problems with RCXPort, and I had to redownload lejos. Maybe this is your problem cause the class just isn't there, or maybe it is there, but something in eclipse can't find it.

Jman
look up and see the chemtrails
www.carnicom.com
User avatar
JavaMan
Novice
 
Posts: 27
Joined: Tue Apr 01, 2008 1:47 pm
Location: United States

RCX Port

Postby Tobi89 » Sat Apr 26, 2008 9:19 am

Which version of eclipse, lejos and lejos eclipse plugin do you use?
Tobi89
New User
 
Posts: 3
Joined: Fri Apr 25, 2008 6:37 pm
Location: Germany

rcxcomm library problem

Postby Tobi89 » Sat Apr 26, 2008 2:49 pm

I downloaded lejos again but I still have the same problem.

I also tried it with other versions of eclipse (version 2),
lejos (version 1.0.5) and lejos eclipse plugin (version 1.0.2)
but I still have the same error.
Tobi89
New User
 
Posts: 3
Joined: Fri Apr 25, 2008 6:37 pm
Location: Germany

Postby JavaMan » Sun Apr 27, 2008 1:27 am

Which version of eclipse, lejos and lejos eclipse plugin do you use?


I actually have never used eclipse. I just thought it was your classpath from the printout. I am using the latest (final) version of lejos.

Maybe you should try using lejos outside of eclipse to see if it is just an eclipse problem.

Jman
look up and see the chemtrails
www.carnicom.com
User avatar
JavaMan
Novice
 
Posts: 27
Joined: Tue Apr 01, 2008 1:47 pm
Location: United States


Return to RCX Software

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff