Compiling with JDK1.5

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

Compiling with JDK1.5

Postby mleonard87 » Wed Jan 31, 2007 1:22 pm

Hi, I have the JDK 1.5 and when i try to compile a leJOS program i get the following error:

Code: Select all
C:\Program Files\Java\lejos\examples\hworld>lejosc HelloWorld.java
javac: target release 1.1 conflicts with default source release 1.5


Is there anyway JDK 1.5 can be used? or do i have to revert to an older version of the Java? If i do need an older version, where can i get it from?

Thanks, Mike
Mike Leonard, University of Surrey (BSc Computer Science and Engineering)
mleonard87
New User
 
Posts: 1
Joined: Wed Jan 31, 2007 1:15 pm

Postby bbagnall » Thu Feb 01, 2007 3:42 am

Hi Mike,

Try using '-source 1.2' as an option for lejosc.
Ex: lejosc -source 1.2 HelloWorld.java
User avatar
bbagnall
Site Admin
 
Posts: 392
Joined: Fri Aug 04, 2006 4:03 pm


Return to RCX Software

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff