Cannot download firmware to RCX, tried firmdl and lejosfirmd

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

Cannot download firmware to RCX, tried firmdl and lejosfirmd

Postby andreyvul » Sun Mar 23, 2008 12:49 am

lejosfirmdl --tty=usb returns with this error:
"write: Resource temporarily unavailable"
firmdl --tty=usb returns with this error:
"Exception in thread "main" java.lang.UnsatisfiedLinkError: ~/lejos_2_1_0/bin/libirtower.so: ~/lejos_2_1_0/bin/libirtower.so: wrong ELF class: ELFCLASS32
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1586)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java: 1511)
at java.lang.Runtime.loadLibrary0(Runtime.java:788)
at java.lang.System.loadLibrary(System.java:834)
at josx.rcxcomm.Tower.<clinit>(Tower.java:126)
at js.tools.Download.open(Download.java:19)
at js.tools.Firmdl.main(Firmdl.java:204)
"
OS: Linux 2.6.24 amd64
Java: Blackdown 1.4.2.03
andreyvul
New User
 
Posts: 1
Joined: Sun Mar 23, 2008 12:38 am

Postby mahado051 » Mon Mar 31, 2008 3:12 am

i have the same porblem...

i tried to install lejos 3.0

but when i want to execute

mahado@linux:~/Lejos$ firmdl
bash: firmdl: orden no encontrada

and i can't install lejos

i wish that you can help us

thanks
mahado051
New User
 
Posts: 3
Joined: Thu Mar 20, 2008 1:45 am

Postby JavaMan » Sun Apr 06, 2008 5:37 pm

Looks like to me something is wrong with your lejos classes. Maybe re-download lejos from the site. Also, why are you calling lejofirmdl?

firmdl is the newest command for downloading the firmware.

Jman
look up and see the chemtrails
www.carnicom.com
User avatar
JavaMan
Novice
 
Posts: 27
Joined: Tue Apr 01, 2008 1:47 pm
Location: United States


Return to RCX Software

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff