Data Abort on startup: Is my brick bricked?

This is where you talk about the NXJ hardware related topics such as the brick, sensors, LEGO pieces, etc.

Moderators: 99jonathan, roger, imaqine

Data Abort on startup: Is my brick bricked?

Postby frosty » Wed May 07, 2008 9:30 am

Hello!

I have a rather worrying problem with my NXT brick.

I've been using LeJOS for quite some time, for a university project, and everything's been fine. However, yesterday I uploaded a new version of some code I'd been working on, and when I next tried turning my NXT on (not running a program, just turning the thing on), I get the LeJOS start screen, and then a data abort error:


Code: Select all
Data abort
PC    00105848
AASR  00446E00
ASR   00020201
OPCODE  184
DEBUG1 00000000
DEBUG2 00000000


Whilst displaying this, the brick clicks as if it was in firmware reset mode, however, if you connect it to a computer, it can't be seen.

I've tried removing the batteries, and using both of the reset buttons, but I can't seem to do anything to restore it.

Is anyone able to help? Or is my brick now just exactly that?
frosty
New User
 
Posts: 9
Joined: Mon Feb 04, 2008 12:54 am

Postby lawrie » Wed May 07, 2008 4:58 pm

You will probably have to flash the leJOS NXJ firmware again. If you try the new 0.6.0 version it has a -f flag to force a format of the file system. You should try that.
lawrie
leJOS Team Member
 
Posts: 909
Joined: Mon Feb 05, 2007 1:27 pm

Postby frosty » Wed May 07, 2008 5:34 pm

Thanks - but how do I get to a stage where I can reflash, though?

The reset button seems to be having no effect, and if I just plug it in while it says data abort, it doesn't appear to be found via USB...
frosty
New User
 
Posts: 9
Joined: Mon Feb 04, 2008 12:54 am

Postby lawrie » Thu May 08, 2008 9:23 pm

The reset button should work if you hold it down for 4 seconds even if the Data Abort has occurred.

Do you get the leJOS splash screen before the data abort occurs?
lawrie
leJOS Team Member
 
Posts: 909
Joined: Mon Feb 05, 2007 1:27 pm

Postby frosty » Thu May 08, 2008 11:38 pm

I do get the leJOS splash screen, and once that goes, the data abort appears.

I've tried holding down the reset button, but the data abort remains on the screen and the brick keeps 'ticking'. If I plug it in via USB and try nxjflash, it says it can't find the brick. :-/
frosty
New User
 
Posts: 9
Joined: Mon Feb 04, 2008 12:54 am

Postby lawrie » Fri May 09, 2008 12:04 pm

Try doing the reset while the splash screen is displayed.
lawrie
leJOS Team Member
 
Posts: 909
Joined: Mon Feb 05, 2007 1:27 pm

Postby frosty » Sat May 10, 2008 1:00 am

Hooray!!

Thanks for the help - I finally got it fixed, by pressing the reset button at the start - turns out the thing I was poking it with wasn't actually pressing the button down :-D

The 0.6 release is really nice, too! Thanks for the Mac support!
frosty
New User
 
Posts: 9
Joined: Mon Feb 04, 2008 12:54 am


Return to NXJ Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

more stuff