Newbie err on firmdl (ThinkPad)

This is where you talk about the RCX software itself, installation issues, and programming talk.

Moderator: roger

Newbie err on firmdl (ThinkPad)

Postby papa » Thu Jun 14, 2007 12:12 am

First attempt at lejos, failing on firmdl.bat
Using a ThinkPad(A30), Win-XP(SP2)
The physical port is 'COM1'; but I don't use it for anything else, and can't be 100% certain that it works - or that lejos is talking to it.

Here's what I see:

C:\Program Files\lejos>firmdl.bat
Error 5: Opening COM1
Open failed: open failure, errno = 5

or, if I try the exe:

C:\Program Files\lejos\bin>lejosfirmdl
Use --help for options.
segment.length[0] = 13686 (14k)
segment.length[1] = 2938 (3k)
Total image size=16624 (17k)
Error 5: Opening COM1

And, just for laughs, I tried THIS (although my tower is on COM port):

C:\Program Files\lejos\bin>lejosfirmdl --tty=usb
Use --help for options.
segment.length[0] = 13686 (14k)
segment.length[1] = 2938 (3k)
Total image size=16624 (17k)
Error 2: Opening \\.\legotower1

Now, this makes me suspicious -- a different error.

So, do I have a Lego (tower) problem, a lejos problem, or a low-level issue with COM1 on this ThinkPad?? (FWIW: the Windows 'device manager' seems to think that COM1 is ok.)

Suggestions???
Thanks!
papa
New User
 
Posts: 2
Joined: Thu Jun 14, 2007 12:03 am
Location: Pittsburgh

[problem solved]

Postby papa » Fri Jun 15, 2007 12:25 am

In fact, it was a low-level system error from COM1. (To establish that, I 'disabled' the port, which made another program complain. Then, knowing which program had grabbed the port, I knew which program to terminate. Having released the port, firmdl was able to run.)
papa
New User
 
Posts: 2
Joined: Thu Jun 14, 2007 12:03 am
Location: Pittsburgh


Return to RCX Software

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests

cron
more stuff