NXT Not Found [RESOLVED]

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

NXT Not Found [RESOLVED]

Postby lethalwire » Thu Jul 12, 2007 7:13 am

Hello.

I began trying to install all of this for a few hours now(5 hours to be exacty)
I must say that most of the tutorials online are wrong.

I searched from lejosfrmdl for I don't know how long. Then the Legos CD almost burned down my computer and rattle my desk apart.

I have most of everything down so far. I just have one last problem. In the readme I am told to:

Type lejoslink Tune -o Tune.bin


After I do this I get the NoClassDefFound and error.

I thought I had all of my classpaths set correctly.
I defined all of:
JAVA_HOME, LEJOS_HOME, LEJOS_Home\bin, java\bin, and RCXTTY=usb, classpath = .

Am I missing anything from here? Does it need to include the jar files I found in the 3rdParty materials?
If I need to include any jar files, how would I add them?
Last edited by lethalwire on Fri Jul 13, 2007 3:23 am, edited 1 time in total.
lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby 99jonathan » Thu Jul 12, 2007 3:33 pm

1. Is Tune in the directory you are in with the command line?
2. If that doesn't work, try putting both Tune and the lejosfrmdl into the same directory, and run it from there with the command line.

Thats all I can think of. I absolutely hate classpath variables...
99jonathan
Moderator
 
Posts: 122
Joined: Thu Mar 01, 2007 5:30 am

Postby lethalwire » Thu Jul 12, 2007 8:28 pm

Yes, my directories were fine. The file compiled perfectly. It just has a problem with the second part of the command.

Also, from what I read, this version of lejos doesn't come with lejosfrmdl.

What versions of lejos are there? 0.2 and 1.5? I was getting some what confused with this. I downloaded a version from December 2006. Then I seen one for maybe march 2007?

By the way, I was in the View Folder compiling View.java.
I'm pretty sure it would do the same with Tune.java.

Off to try more things to make this work... I don't see why it's so difficult for some people and flawless for others.


I tried the 'lejosdl' command just for kicks and giggles and get:
NXT not found. Is it properly plugged in via USB?


Does this have something to do with LIBusb? I installed the program.
Worthless Attempts:
Directory of C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune

07/11/2007 10:50 PM <DIR> .
07/11/2007 10:50 PM <DIR> ..
03/30/2007 06:53 PM 1,619 Tune.bin
03/30/2007 06:53 PM 845 Tune.java
2 File(s) 2,464 bytes
2 Dir(s) 74,471,739,392 bytes free

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejosjc Tune.java

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejoslink Tune -o Tune.bin

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>echo off
Exception in thread "main" java.lang.NoClassDefFoundError: and

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejoslink Tune -o Tune.bin

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>echo off
Exception in thread "main" java.lang.NoClassDefFoundError: and

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejosjc Tune.java

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejoslink Tune -o Tune.bin

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>echo off
Exception in thread "main" java.lang.NoClassDefFoundError: and

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejosdl Tune.bin
NXT not found. Is it properly plugged in via USB?

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>lejosdl Tune.bin
NXT not found. Is it properly plugged in via USB?

C:\Documents and Settings\Administrator\Desktop\Java\Lejos\samples\Tune>

lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby lethalwire » Thu Jul 12, 2007 10:04 pm

Ok, here I go.
I'm going to install this directly into the C:\ Drive. That'll get rid of the spaces in the directory.

Instead of C:\Documents AND Settings\

I think the spaces are killing me. I think Lejos is Killing me :P
lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby cdrh » Thu Jul 12, 2007 10:24 pm

I found that using the following is necessary after running lejosjc:

lejoslink -o MyCode.bin MyCode

After you run the above command in your command line you should not have a problem with the lejosdl command. This works for lejos 0.2
cdrh
New User
 
Posts: 2
Joined: Wed May 30, 2007 12:27 am

Postby lethalwire » Thu Jul 12, 2007 10:43 pm

It was the space before the word "and" that was bugging the variables out.

Now I just can't get the command line to stop saying
NXT not found. Is it properly plugged in via USB?



I don't understand. It's coming up correctly in the device manager.
lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby lethalwire » Fri Jul 13, 2007 9:08 pm

Any help with this problem would be greatly appreciated. I believe I have it all figured out except for this (I hope) problem.

I've tried googling the error, but I see no responses to the question. Just the question itself.
lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby lethalwire » Sun Jul 15, 2007 10:08 pm

Eureka I finally got it!
I swear I'm going to have to write a tutorial on what I have done to make this work. WOot :P
lethalwire
New User
 
Posts: 7
Joined: Thu Jul 12, 2007 7:04 am

Postby PantsOnToast » Mon Jul 16, 2007 6:15 pm

I am using the newest version, 0.3, and I am pretty much stuck exactly where you are, I am getting the same NXT not found message. I was hoping you would share what you did to solve the problem. Thanks.
PantsOnToast
New User
 
Posts: 10
Joined: Mon Jul 16, 2007 6:13 pm

Postby PantsOnToast » Mon Jul 16, 2007 6:34 pm

Nevermind on that one, I simply needed to load the firmware for 0.3 using the command nxjflash and follow different steps for compiling and uploading the program that are new to 0.3. I am learning as I go and will probably post my own tutorial that uses 0.3 in the future.
PantsOnToast
New User
 
Posts: 10
Joined: Mon Jul 16, 2007 6:13 pm


Return to NXJ Software

Who is online

Users browsing this forum: Google [Bot] and 1 guest

more stuff