Complete Instructions to installing NXJ firmware[SOLVED]

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

Complete Instructions to installing NXJ firmware[SOLVED]

Postby monkey525467 » Mon Jul 16, 2007 4:46 pm

I have tried and tried to install the new firmware, but I cannot figure anything out. I'm not sure what I'm doing wrong (or not doing for that matter). Could someone please give me all the instructions clearly from step one?

Thanks! :)
Last edited by monkey525467 on Wed Dec 09, 2009 12:06 am, edited 1 time in total.
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am

Postby imaqine » Mon Jul 16, 2007 5:50 pm

Welcome to the forum!

Now by the new firmware I assume you mean version .3?

Can you be a bit more descriptive? What have you been able to do and what exactly are you having issues with. What exactly can you not figure out? The new version was released yesterday I believe and I have yet to have a chance to take a look at it. I would say make sure you pay CLOSE attention to the read me document and ask specific questions on what you are having trouble with therefore there will be a more likely chance that your question gets answered.

BTW, Have you tried using any of the previous versions of NXJ?
imaqine
Moderator
 
Posts: 79
Joined: Sun Apr 08, 2007 6:20 am

Postby monkey525467 » Mon Jul 16, 2007 6:06 pm

Yes I am using .3 and my problem lies in the read me. What I don't really understand is in the "Using leJOS NXJ" section when it tells you to flash the firmware using nxjflash. What does it mean to flash, and how do I do this.

Oh and by the way, I'm using WinXP in case you were wondering. I have never used NXJ before.

Hope this will help you help me. :D

Thanks!
We must not let technology overtake us; we must harness the power of it --Carson Shook
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am

Postby imaqine » Tue Jul 17, 2007 12:19 pm

Flashing the firmware means to upload the NXJ firmware onto the NXT brick. This is done through the command line. START > RUN > CMD
imaqine
Moderator
 
Posts: 79
Joined: Sun Apr 08, 2007 6:20 am

Postby monkey525467 » Tue Jul 17, 2007 9:32 pm

Well, I found out where to type 'nxjflash', but I got the following error: checking VM c:\lejos;c:\lejos\lejos_nxj/bin/lejos_nxt_rom.bin ... Error in VM File: File open/handling error

What am I doing wrong? :?
We must not let technology overtake us; we must harness the power of it --Carson Shook
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am

Postby imaqine » Wed Jul 18, 2007 12:33 pm

Have you setup your environment variables correctly? JAVA_HOME, and NXJ_HOME?

You can do this by going to Start > Control Panel > System and clicking the Advanced tab to get to the environment variables. This is on a Windows computer only.
imaqine
Moderator
 
Posts: 79
Joined: Sun Apr 08, 2007 6:20 am

Postby monkey525467 » Wed Jul 18, 2007 2:04 pm

I'm pretty sure I have them correct, but just to be on the safe side could you give me them exactly?

Thanks
We must not let technology overtake us; we must harness the power of it --Carson Shook
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am

Postby lawrie » Wed Jul 18, 2007 9:58 pm

You should have NXJ_HOME set to c:\lejos\lejos_nxj

It looks from your error message as if you have it set to

c:\lejos;c:\lejos\lejos_nxj
lawrie
leJOS Team Member
 
Posts: 922
Joined: Mon Feb 05, 2007 1:27 pm

Postby imaqine » Thu Jul 19, 2007 12:23 pm

Jimswartz had the same problem in this thread: http://lejos.sourceforge.net/forum/viewtopic.php?p=814.
imaqine
Moderator
 
Posts: 79
Joined: Sun Apr 08, 2007 6:20 am

Postby monkey525467 » Thu Jul 19, 2007 2:01 pm

It's a funny story actually, but before you replied to my last post, actually figured out my own problem, and I solved it.

Thanks for all your hard work imaquine! :D :D
We must not let technology overtake us; we must harness the power of it --Carson Shook
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am

Postby imaqine » Thu Jul 19, 2007 5:28 pm

Nice! I am glad to hear that you got everything working.

Can you post whatever you did to solve your problem(s) in case someone else is having the same problem that you were having?
imaqine
Moderator
 
Posts: 79
Joined: Sun Apr 08, 2007 6:20 am

Postby monkey525467 » Sun Jul 22, 2007 1:38 pm

I checked the environment variables and I realized that I had to add one more '\lejos_nxj' to the NXJ_HOME variable. In the end, NXJ_HOME was set to: C:\Java\lejos_nxj\lejos_nxj

Hope this helps any others with the same problem 8)
We must not let technology overtake us; we must harness the power of it --Carson Shook
User avatar
monkey525467
New User
 
Posts: 21
Joined: Sun Jul 08, 2007 2:18 am


Return to NXJ Software

Who is online

Users browsing this forum: gloomyandy, Yahoo [Bot] and 2 guests

more stuff