Can't find lejosfirmdl with 0.3.0alpha version

This is where you talk about the NXJ software itself, installation issues, and programming talk.

Moderators: 99jonathan, roger, imaqine

Can't find lejosfirmdl with 0.3.0alpha version

Postby rasca » Thu Aug 02, 2007 8:38 am

Hi Everybody,
finally i've compiled with ant the lejos package version 0.3.0alpha (something with the includes was broken but by editing the build.xml with the correct includes everything compiled fine). Now i'm searching for the lejosfirmdl executable to upgrade the firmware of the NXT... I canno't find this command anyware... So where it is ?
These are the files i have in the bin dir :

emu-lejosrun
lejos_nxt_rom.bin
lejos_nxt_samba_ram.bin
libjbluez.so
libjlibnxt.so
nxj
nxjbrowse
nxjc
nxjflash
nxjlink
nxjupload
StartUpText.bin

my system is a Debian Lenny with apache-ant-1.7.0 and jdk1.6.0_02.

Can somebody give me some hints ?

Thanks,

--
RaSca
rascasoft@tiscali.it
rasca
New User
 
Posts: 3
Joined: Thu Aug 02, 2007 8:15 am

Postby rasca » Thu Aug 02, 2007 1:37 pm

The right information on how to do the firmware update are in the README.html file that is in the lejos_nxj directory which says that the correct command is nxjflash instead of lejosfirmdl.

This means that the Maximum book is wrong :-(

I'm only at the begin of this book and this experience is not started in the better way...

Bye,

--
RaSca
rascasoft@tiscali.it
rasca
New User
 
Posts: 3
Joined: Thu Aug 02, 2007 8:15 am


Return to NXJ Software

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 4 guests

more stuff